Cisco Vs Huawei LAB O – (Configuring Inter-VLAN Routing)

Configuring inter-VLAN communication allows users in different VLANs to communicate with each other. Learn how to configure Inter-VLAN routing, also known as Router on a Stick by configuring a switch to trunk to a router with sub-interfaces in each VLAN.

CISCO
NetworksHeaven(config)#configure terminal
NetworksHeaven(config)#interface GigabitEthernet0/0
NetworksHeaven(config-if)#no shutdown
NetworksHeaven(config-if)#exit

NetworksHeaven(config)#interface GigabitEthernet0/0.15
NetworksHeaven(config-subif)#encapsulation dot1Q 15
NetworksHeaven(config-subif)#ip add 15.1.1.10 255.0.0.0
NetworksHeaven(config-subif)#end

NetworksHeaven(config)#interface GigabitEthernet0/0.5
NetworksHeaven(config-subif)# encapsulation dot1Q 5
NetworksHeaven(config-subif)# ip add 5.1.1.10 255.0.0.0
NetworksHeaven(config-subif)#exit

HUAWEI
<NetworksHeaven> system-view
[NetworksHeaven] interface GigabitEthernet0/0
[NetworksHeaven-GigabitEthernet0/0/1] undo shutdown
[NetworksHeaven-GigabitEthernet0/0/1] quit
[NetworksHeaven]

[NetworksHeaven] interface GigabitEthernet0/0.5
[NetworksHeaven-GigabitEthernet0/0/1.5] vlan-type dot1q 5
[NetworksHeaven-GigabitEthernet0/0/1.5] ip address 5.1.1.10 255.0.0.0
[NetworksHeaven-GigabitEthernet0/0/1.5] quit

[NetworksHeaven] interface GigabitEthernet0/0.15
[NetworksHeaven-GigabitEthernet0/0/1.15] vlan-type dot1q 15
[NetworksHeaven-GigabitEthernet0/0/1.15] ip address 15.1.1.10 255.0.0.0
[NetworksHeaven-GigabitEthernet0/0/1.15] quit

Cisco Vs Huawei CLI Commands in Slides